Title
The feature test macro for ranges::find_last should be renamed
Status
ready
Section
[version.syn]
Submitter
Daniel Marshall

Created on 2022-11-02.00:00:00 last changed 3 weeks ago

Messages

Date: 2022-11-12.01:01:24

Proposed resolution:

This wording is relative to N4917.

  1. Modify [version.syn], header <version> synopsis, as indicated:

    […]
    #define __cpp_lib_filesystem              201703L // also in <filesystem>
    #define __cpp_lib_ranges_find_last        202207L // also in <algorithm>
    #define __cpp_lib_flat_map                202207L // also in <flat_map>
    […]
    
Date: 2022-11-12.01:01:24

[ Kona 2022-11-12; Move to Ready ]

Date: 2022-11-02.00:00:00

The current feature test macro is __cpp_lib_find_last which is inconsistent with almost all other ranges algorithms which are in the form __cpp_lib_ranges_xxx.

Proposed resolution is to rename the macro to __cpp_lib_ranges_find_last.

History
Date User Action Args
2022-11-12 01:01:24adminsetmessages: + msg13031
2022-11-12 01:01:24adminsetstatus: new -> ready
2022-11-05 13:54:46adminsetmessages: + msg12925
2022-11-02 00:00:00admincreate