Created on 2009-11-20.00:00:00 last changed 143 months ago
[Voted into WP at March, 2010 meeting.]
Proposed resolution (February, 2010):
Change the index to refer to “implicit object parameter” and “implied object argument” instead of the current permutations of these terms.
Change 12.2 [over.match] paragraph 1 as follows:
...how well (for non-static member functions) the object matches the
Change 12.2.2 [over.match.funcs] paragraph 4 as follows:
...For conversion functions, the function is considered to be a member of the class of the
implicitobject argument for the purpose of defining the type of the implicit object parameter...
Change the footnote in 12.2.4 [over.match.best] paragraph 1 bullet 1 as follows:
The terminology used to refer to the parameter for this and its corresponding argument is inconsistent, sometimes using “implied” and sometimes “implicit.” It would be easier to search the text of the Standard if this usage were made regular.
|2010-03-29 00:00:00||admin||set||messages: + msg2723|
|2010-03-29 00:00:00||admin||set||status: tentatively ready -> cd2|
|2010-02-16 00:00:00||admin||set||messages: + msg2506|